Service Issue Reported – EBSCOhost / EBSCO Discovery Service
Incident Report for EBSCO Alert
Resolved
The issues impacting the visual appearance of the interface in EBSCOhost/EBSCO Discovery Service are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted 3 months ago. May 13, 2019 - 17:38 UTC
Identified
EBSCO Customer Support has received reports of an issue with EBSCOhost / EBSCO Discovery Service impacting the visual appearance of the interface. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted 3 months ago. May 13, 2019 - 12:59 UTC
This incident affected: EBSCOhost Research Databases, EBSCO Discovery Service, and Full Text Finder.