Service Issue Reported – EBSCOadmin Authentication
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCOadmin Authentication are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Feb 01, 2023 - 03:50 UTC
Investigating
We have received reports of an issue with EBSCOadmin Authentication Single Sign-on (SSO). Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Feb 01, 2023 - 03:28 UTC
This incident affected: EBSCOadmin.