Service Issue Reported – Search in EBSCO Discovery Service - New UI
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCO Discovery Service - New UI are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Dec 02, 2021 - 01:38 UTC
Investigating
EBSCO Customer Support has received reports of an issue with search not functioning in EBSCO Discovery Service - New UI. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Dec 02, 2021 - 00:50 UTC
This incident affected: EBSCO Discovery Service - New UI.