Service Issue Reported – EBSCO Discovery Service - New UI and EBSCO Mobile App
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCO Discovery Service - New UI and EBSCO Mobile App are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Sep 16, 2021 - 21:57 UTC
Monitoring
A fix has been implemented. We have validated that service has been restored. Engineering Teams are monitoring further.
Posted Sep 16, 2021 - 21:48 UTC
Identified
Engineering teams have identified the root cause and is working on a potential fix. More updates to follow shortly.
Posted Sep 16, 2021 - 21:39 UTC
Investigating
EBSCO Customer Support has received reports of an issue with EBSCO Discovery Service - New UI and EBSCO Mobile App. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Sep 16, 2021 - 21:36 UTC
This incident affected: EBSCO Discovery Service - New UI and EBSCO Mobile App.