Service Issue Reported – eBooks
Incident Report for EBSCO Alert
Resolved
This incident has been resolved.
Posted Jul 17, 2019 - 23:03 UTC
Investigating
EBSCO Customer Support has received reports of an issue with eBooks. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Jul 17, 2019 - 21:01 UTC
This incident affected: EBSCO eBooks.