Service Issue Reported – EDS/EBSCOhost
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EDS/EBSCOhost are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted 6 months ago. Jan 16, 2019 - 20:04 UTC
Investigating
EBSCO Customer Support has received reports of an issue with latency when searching in EDS/EBSCOhost. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted 6 months ago. Jan 16, 2019 - 18:59 UTC
This incident affected: EBSCOhost Research Databases and EBSCO Discovery Service.