Service Issue Reported – EBSCO Connect Latency
Incident Report for EBSCO Alert
Resolved
This incident has been resolved.
Posted Oct 25, 2019 - 23:01 UTC
Investigating
EBSCO Customer Support has received reports of an issue with EBSCO Connect. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Oct 25, 2019 - 15:12 UTC
This incident affected: EBSCO Connect.