Service Issue Reported – EBSCO Discovery Service
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCO Discovery Service are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Dec 02, 2022 - 16:19 UTC
Update
We are continuing to investigate this issue.
Posted Dec 02, 2022 - 16:17 UTC
Investigating
We have received reports of an issue with search results in EBSCO Discovery Service. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Dec 02, 2022 - 15:57 UTC
This incident affected: EBSCO Discovery Service.